Computers and Technology
Computers and Technology, 15.10.2020 19:01, 8hoofs

HW3_P2 - MyString The String class is provided in the Java library. Provide your own implementation for the following methods (name the new class MyString):
**PLEASE DO NOT USE THE STRING OBJECT AND ITS METHODS. IMPLEMENT THEM ALL AGAIN YOURSELF!
**You can use char[] array and Character object.
public MyString(char[] chars);
public char charAt(int index);
public int length();
public MyString substring(int begin, int end);
public MyString toLowerCase();
public boolean equals(MyString s);
public static MyString valueOf(int i); // Convert int type to MyString type
public char[] toChars();
Sample Input1: Test Length() Method
1
abcdef
Sample Output1: Test Length() Method
4
Sample Input2: Test charAt() Method
2
abcdfeg
3
Sample Output2: Test charAt() Method
d
Sample Input3: Test substring() Method
3
abcdefrgggfhgfgfhfgy
0
4
Sample Output3: Test substring() Method
abcd
Sample Input4: Test equals() Method
4
abcdefghi
sqsq
Sample Output4: Test equals() Method
false
Sample Input5: Test toLowerCase() Method
5
ABcDEfGHi
Sample Output5: Test toLowerCase() Method
abcdefghi
Sample Input6: Test valueOf() Method
6
9876543
Sample Output6: Test valueOf() Method
9876543
*Drivers Class*
import java. util.*;
import java. lang.*;
import java. io.*;
public class Driver {
public static void main(String[] args){
String str = null;
MyString s = null;
Scanner input = new Scanner(System. in);
int which = input. nextInt();
if(which!=6)
str = input. next();
switch (which) {
case 1 : // test length method
s = new MyString(str. toCharArray());
System. out. println(s. length());
break;
case 2 : // test charAt method
s = new MyString(str. toCharArray());
System. out. println(s. charAt(input. nextInt()));
break;
case 3 : // test substring method
s = new MyString(str. toCharArray());
System. out. println(new String(s. substring(input. nextInt(), input. nextInt()).toChars()));
break;
case 4 : // test equals method
String str2 = input. next();
s = new MyString(str. toCharArray());
MyString s2 = new MyString(str2.toCharArray());
System. out. println(s. equals(s2));
break;
case 5 : // test toLowerCase method
s = new MyString(str. toCharArray());
System. out. println(new String(s. toLowerCase().toChars()));
break;
case 6 : // test valueOf method
System. out. println(new String(MyString. valueOf(input. nextInt()).toChars()));
break;
}
}
}
*Solution class*
import java. util.*;
import java. lang.*;
import java. io.*;
//toChars() method is already implemented, so plese do not change it
class MyString {
private char[] chars;
public MyString(char[] chars) {
}
public char[] toChars() { //Do not change this method
return chars;
}
public int length()
}
public char charAt(int index) {
}
public MyString substring(int begin, int end) {
}
public boolean equals(MyString s){
}
public MyString toLowerCase() {
}
//convert an int type to MyString type
public static MyString valueOf(int i) {
}
}
Dont change driver class or myString. just add code

answer
Answers: 2

Other questions on the subject: Computers and Technology

image
Computers and Technology, 22.06.2019 11:30, jcazares3558
Awell-diversified portfolio needs about 20-25 stocks from different categories.
Answers: 2
image
Computers and Technology, 22.06.2019 22:30, Metlife
You are new to microsoft certification and want to start out by getting a certification geared around windows 8. what microsoft certification should you pursue?
Answers: 1
image
Computers and Technology, 23.06.2019 23:00, minosmora01
How do you know if the website is secure if you make a purchase
Answers: 2
image
Computers and Technology, 24.06.2019 04:30, juliemiddleton05
1. web and mobile applications allow users to be actively engaged in an online activity. a true b false 2. some examples of business applications purposes are to collaborate, share files, meet virtually in real-time, and accept payments. a true b false 3. an education application would most likely do which of the following? a allow users to watch popular movies and tv shows b connect users with social and business contacts c confirm users' travel plans d teach users a new language 4. a uniform resource locator (url) is how the internet knows where to take users when an address is typed into a browser. a true b false 5. deon is required to provide the citation information for his sources. what type of information should he collect from his sources? a author name, title, date of publication, date of access, url b connections to background information c interesting facts and statistics d notes on important information
Answers: 1
Do you know the correct answer?
HW3_P2 - MyString The String class is provided in the Java library. Provide your own implementation...

Questions in other subjects:

Konu
Mathematics, 16.07.2021 22:30
Konu
Mathematics, 16.07.2021 22:30